Задать вопрос

Напишите программу которая заполняет массив А[1 ... 5,1 ... 5] по правилу a [i; j]:=i+j

+4
Ответы (1)
  1. 10 сентября, 17:06
    0
    program zz1;

    const n = 5;

    b = 5; / / задаем количество элементов в массиве

    var i, j:integer; / / задаем переменные целого типа

    m:array [1 ... n, 1 ... b] of integer; / / описываем массив целого типа

    begin

    for i:=1 to n do

    for j:=1 to b do / / получаем числа по заданному правилу и записываем их в массив

    m[i, j]:=i + j;

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to b do

    write (m[i, j]:4);

    writeln; / / переходим на новую строку

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу которая заполняет массив А[1 ... 5,1 ... 5] по правилу a [i; j]:=i+j ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив, в котором заменены на противоположные знаки элементов исходного массива.
Ответы (1)
компьютерный вирус А заполняет 1 Гбайт за 1 месяц, вирус В заполняет 1 Гбайт за 2 месяца, вирус С заполняет 1 Гбайт за 3 месяца, вирус D заполняет 1 Гбайт за 6 месяцев. На компе обнаружено сразу 4 вируса.
Ответы (1)
Компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за три месяца, вирус D заполняет 1 Гбайт за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса.
Ответы (1)
Напишите программу, которая заполняет массив случайными целыми числами, вводит с клавиатуры целое число N и копирует в новый массив все числа из исходного массива, для которых сумма значений всех цифр равна N.
Ответы (1)