Задать вопрос
24 марта, 14:15

Дана последовательность целых чисел A1, A2, ..., An. Составьте программу, которая выводит разность произведения элементов с нечётным индексом и суммы элементов с чётным индексом.

+2
Ответы (1)
  1. 24 марта, 16:50
    0
    program zz1;

    const n = 7; / / задаем количество элементов в массиве

    R:array [1 ... n] of integer = (4, - 1, 5, 6, - 7, 9, - 6); / / задаем последовательность чисел

    var i, k, m:integer; / / задаем переменные целого типа

    begin

    k:=1; m:=0; / / задаем начальное значение для произведения и суммы

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    begin

    if i mod 2 = 1 then k:=k * R[i]; / / проверяем, если индекс нечетный, то умножаем элемент на произведение

    if i mod 2 = 0 then m:=m + R[i]; / / проверяем, если индекс четный, то добавляем элемент в сумму

    end;

    write (' разность произведения и суммы = ', k - m); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность целых чисел A1, A2, ..., An. Составьте программу, которая выводит разность произведения элементов с нечётным ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Дан массив целых чисел А (10). Элементы с нечетным индексом заменить минимальным элементом
Ответы (1)
Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив, в котором заменены на противоположные знаки элементов исходного массива.
Ответы (1)
Составьте программу которая выводит на экран пример на умножение двух однозначных чисел, запрашивает ответ пользователя. проверяет его и выводит соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись". а также правильный результат.
Ответы (1)