Задать вопрос

Найти среднее время, затрачиваемое на выполнение домашнего задания учениками. В классе 24 человека, затрчаиваемое время случайно в диапазоне от 3 до 76 минут. На языке Паскаль составить программу

+1
Ответы (1)
  1. 21 августа, 01:49
    0
    program zz1;

    const n = 24; / / задаем количество элементов в массиве

    var i, k, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (74) + 3;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    begin s:=s + m[i]; k:=k + 1; end; / / получаем сумму и количество элементов

    write (' среднее время, затрачиваемое на выполнение домашнего задания учениками = ', s/k:5:2); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти среднее время, затрачиваемое на выполнение домашнего задания учениками. В классе 24 человека, затрчаиваемое время случайно в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Дано N случайных чисел в диапазоне от - 3 до 3. Вычислите, сколько из них не совпадают с 0. Составить программу, используя цикл for. Для задания случайных ч исел используйте функцию random. N определяет пользователь. Числа вывести на экран.
Ответы (1)