Задать вопрос
6 декабря, 19:32

С клавиатуры вводятся последовательно из k целых чисел вычислить произведение нечетных членов последовательности

+3
Ответы (1)
  1. 6 декабря, 21:45
    0
    var

    a, i : integer; / / объявляем переменные целочисленного типа.

    begin

    i : = 1; / / нужно, чтобы при подсчете произведения не умножать на ноль.

    a : = 1;

    writeln ('введите последовательность положительных чисел, окончание ввода - число 0:');

    while a 0 do / / начало цикла.

    begin

    readln (a); / / считываем число, введенное с клавиатуры.

    if (a mod 2 > 0) then / / если число нечетное, то считаем произведение.

    i : = i * a;

    end;

    write ('Произведение нечетных чисел равно: ', i); / /вывод ответа на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводятся последовательно из k целых чисел вычислить произведение нечетных членов последовательности ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Дан массив А целых чисел, состоящий из 20 элементов. Заполнить с клавиатуры. К чётным элементам прибавить А, а от нечётных отнять В (числа вводятся с клавиатуры).
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)
Вычислить произведение целых чисел введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа в интервале от - 10 до + 10 через repeat ... until
Ответы (1)