Задать вопрос
8 августа, 17:31

Найти среднее арифметическое трех целых случайных чисел, принадлежащих промежутку {0; 10)

+3
Ответы (1)
  1. 8 августа, 20:07
    0
    program zz1;

    var a, b, c:integer; / / задаем переменные целого типа

    i:real; / / задаем переменную не целого типа

    begin

    a:=random (10); / / получаем первое случайное число

    b:=random (10); / / получаем первое случайное число

    c:=random (10); / / получаем первое случайное число

    i: = (a + b + c) / 3; / / вычисляем среднее арифметическое полученных трех случайных чисел

    write (' среднее арифметическое трех целых случайных чисел = ', I:6:2); / / выводим ответ в формате шесть знаков для всего числа и два знака после точки

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти среднее арифметическое трех целых случайных чисел, принадлежащих промежутку {0; 10) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Составить программу, которая формирует массив А из 85 случайных целых чисел, принадлежащих промежутку [4; 14]. Параметром цикла является переменная s. Нумерация начинается с 1
Ответы (1)
составьте программу которая формирует массив из 12 случайных целых чисел принадлежащих промежутку [-5; 5] и выводит эти числа в столбец.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
Создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество элементов массива, значения которых превышают средне арифметическое значений его элементов
Ответы (1)