Задать вопрос
7 декабря, 05:49

Ввести предложение, где между словами не менее одного пробела. Вывести слова в столбец.

+1
Ответы (1)
  1. 7 декабря, 08:31
    0
    program zz1;

    var s, d:string; / / задаем переменные строкового типа

    k:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    s:=s+' '; / / добавляем в конец строки пробел для того чтобы цикл закончился

    while s'' do / / организуем цикл, пока строка не пуста

    begin

    k: = pos (' ', s); / / получаем позицию пробела

    d: = copy (s, 1, k); / / копируем слово до пробела

    writeln (d); / / выводим слово с новой строки

    delete (s, 1, k); / / удаляем слово с пробелом

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести предложение, где между словами не менее одного пробела. Вывести слова в столбец. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)
ввести 3 стороны треугольника, вывести его площадь. (на языке паскаль) ввести число, вывести квалратный корень.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)