Задать вопрос

Дан массив n на m найдите минимальное трехзначное число, записанное в массиве. если таких чисел нет, то вывести сообщение "Таких чисел нет"

+3
Ответы (1)
  1. 2 ноября, 03:47
    0
    program zz1;

    const n = 3;

    m = 3; / / задаем количество элементов в массиве

    var i, j, min:integer; / / задаем переменные целого типа

    b:array [1 ... n, 1 ... m] of integer;

    begin

    for i:=1 to n do

    for j:=1 to m do / / получаем числа и записываем их в массив

    b[i, j]:=random (501);

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to m do

    write (b[i, j]:4);

    writeln;

    end;

    min:=100000;

    for i:=1 to n do

    for j:=1 to m do

    begin

    if (b[i, j]>99) and (b[i, j]<1000) then if b[i, j] < min then min:=b[i, j];

    end;

    if min = 100000 then write (' таких чисел нет ') else write (' минимальное трехзначное число массива = ', min);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив n на m найдите минимальное трехзначное число, записанное в массиве. если таких чисел нет, то вывести сообщение "Таких чисел нет" ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дан массив, состоящий из 100 целых чисел: а) Вывести все числа, которые встречаются в этом массиве по нескольку раз; б) Вывести все числа, которые встречаются в массиве только по одному разу.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)