Задать вопрос

2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

+1
Ответы (1)
  1. 7 ноября, 20:02
    0
    program zz1;

    var x, y:integer; / / задаем переменные целого типа

    begin

    y:=0;

    read (x); / / вводим первое число последовательности

    if x > y then y:=x;

    while x 0 do / / организуем цикл, в котором будем вводить числа последовательности, пока не введем ноль

    begin

    read (x); / / вводим следующее число последовательности

    if x > y then y:=x; / / проверяем, если число последовательности больше максимального, то записываем его в максимальное

    end;

    write (' максимальное число последовательности = ', y); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить все символы, начиная с середины.
Ответы (1)
Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное, оканчивающееся на 1. Программа получает на вход кол-во чисел в последовательности, а затем сами числа.
Ответы (1)
Напишите программу, которая в последовательности N натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход N-ное количество чисел. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Составить программу на языке pascal. используя цикл repeat ... until. Определить минимальное число из введенной с клавиатуры последовательности положительных чисел, ввод заканчивается отрицательным числом.
Ответы (1)