Задать вопрос
20 декабря, 15:19

дан массив. выведите его элементы, которые встречаются в массиве только один раз

+1
Ответы (1)
  1. 20 декабря, 19:17
    0
    program zz1;

    const n = 15; / / задаем количество элементов в массиве

    var i, j, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51) - 25;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    begin

    for j:=1 to n do

    if m[i] = m[j] then k:=k+1; / / считаем сколько раз элемент встречается

    if k = 1 then write (m[i],' '); / / если один раз, то выводим на экран

    k:=0;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «дан массив. выведите его элементы, которые встречаются в массиве только один раз ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан массив, состоящий из 100 целых чисел: а) Вывести все числа, которые встречаются в этом массиве по нескольку раз; б) Вывести все числа, которые встречаются в массиве только по одному разу.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
В массиве хранится информация о среднедневной температуре ноября (в С°) 1. Опишите данный массив. 2. Заполните массив случайными целыми числами из отрезка [-3; 7]. 3. Выведите элементы данного массива в строчку через пробел. 4.
Ответы (1)
1. Дан массив натуральных чисел. Напечатать все элементы массива, являющиеся двузначными числами. 2. Дан массив. Напечатать четные элементы. 3. Все элементы массива с четными номерами удвоить, с нечетными - уменьшить на 1.
Ответы (1)