Задать вопрос

Составить программу в паскале для решения квадратного уравнения ax^2+bx+c=0

+5
Ответы (1)
  1. 2 июля, 13:30
    0
    programm kvadratnoeuravnenie;

    var a, b, c, x1, x2, d: integer;

    begin

    writeln ('Введите коэффициент стоящий перед квадратом х');

    readln (a);

    writeln ('Введите коэффициент стоящий перед х');

    readln (b);

    writeln ('Введите коэффициент свободного слагаемого');

    readln (c);

    d = sqr (b) - 4 * a * c;

    if d < 0

    then

    writeln ('Дискриминант меньше нуля, поэтому квадратное уравнение не будет иметь действительных корней')

    else

    x1: = (-b - sqrt (d)) / (2 * a);

    x2: = (-b + sqrt (d)) / (2 * a);

    writeln ('Первый корень уравнения = ', x1);

    writeln ('Второй корень уравнения = ', x2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу в паскале для решения квадратного уравнения ax^2+bx+c=0 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)
Программу в паскале. Составить программу нахождения произведения положительных чисел одномерного массива В (10), элементы которого задаются датчиком случайных чисел.
Ответы (1)
Составьте программу для вычисления значения функции y = sinx + 1/x, для которой значение аргумента x введите с клавиатуры. (на Паскале) Наладить программу так, чтобы x = 5; y = - 0.758924
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)