Задать вопрос

Пусть дано 10 вещественных чисел, которые вводятся по одному. Вычисли-те разность между максимальным и минимальным числами. паскаль ABC

+4
Ответы (1)
  1. 1 ноября, 12:31
    0
    program zz1;

    var i:integer; / / задаем переменную целого типа

    a, max, min:real; / / задаем переменные вещественного типа

    begin

    max:=0; min:=100000;

    for i:=1 to 10 do

    begin

    read (a); / / вводим число

    if a > max then max:=a; / / проверяем, если число больше максимального, то записываем его в максимальное

    if a < min then min:=a; / / проверяем, если число меньше минимального, то записываем его в минимальное

    end;

    write (' разность между максимальным числом и минимальным = ', max - min); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Пусть дано 10 вещественных чисел, которые вводятся по одному. Вычисли-те разность между максимальным и минимальным числами. паскаль ABC ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая вводит с клавиатуры 15 реальных чисел, организовывает их хранение в массиве и определяет разность между максимальным и минимальным элементом массива.
Ответы (1)
Пусть дано 100 целых чисел, которые вводятся по одному. Найдите количество элементов больших числа 10 и кратных 3
Ответы (1)
Подсчитать сумму элементов, расположенных между максимальным и минимальным элементами. Если максимальный элемент встречается позже минимального, то выдать сообщение об этом.
Ответы (1)
Нарисовать N концентрических окружностей с минимальны радиусом r и максимальным радиусом R c центром с координатами X и Y. N, r, R, X, Y вводятся с клавиатуры. pascal abc
Ответы (1)
Даны натуральное число x и целые числа a₁, a₂, ..., aₓ. Найти: а) номер максимального из чисел aₓ. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел aₓ.
Ответы (1)