Задать вопрос
17 марта, 09:31

Пусть дано 100 целых чисел, которые вводятся по одному. Найдите количество элементов больших числа 10 и кратных 3

+1
Ответы (1)
  1. 17 марта, 10:36
    0
    program zz1;

    var i, s, n:integer; / / задаем переменные целого типа

    begin

    for i:=1 to 100 do / / организуем цикл на сто повторений

    begin

    read (n); / / вводим очередное число с клавиатуры

    if (n > 10) and (n mod 3 = 0) then s:=s + 1; / / проверяем условие, если введенное число больше десяти и оно же делится на три без остатка, то считаем его

    end;

    writeln (' количество найденных чисел среди введенных = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Пусть дано 100 целых чисел, которые вводятся по одному. Найдите количество элементов больших числа 10 и кратных 3 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
С клавиатуры последовательно вводятся 15 разных целых чисел, которые размещаются в массиве. Напишите программу, которая выводит на экран количество элементов массива кратных 5 и минимальное среди подходящих под это условие.
Ответы (1)