Задать вопрос

Дана длина L окружности. Найти ее радиус R и площадь S круга, ограниченного этой окружностью, учитывая, что L = 2*Pi*R, S = Pi*R2. В качестве значения Pi использовать 3.14. В паскале, код нужен к задаче.

+2
Ответы (1)
  1. 12 мая, 05:04
    0
    program zz1;

    var r, L, S:real; / /задаем переменные не целого типа

    begin

    write ('введите исходное значение длины окружности '); / /вводим с клавиатуры исходное значение L

    read (L);

    R:=L / 2 * pi; / / вычисляем радиус окружности по заданной формуле

    writeln (' полученное значение радиуса окружности = ', R:5:2); / /выводим ответ в формате пять знаков для всего числа и два знака после запятой

    S: = pi * R * R; / / вычисляем площадь окружности по заданной формуле

    write (' полученное значение площади окружности = ', S:5:2); / /выводим ответ в формате пять знаков для всего числа и два знака после запятой

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана длина L окружности. Найти ее радиус R и площадь S круга, ограниченного этой окружностью, учитывая, что L = 2*Pi*R, S = Pi*R2. В ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана длина окружности. Найти площадь круга ограниченного этой окружностью. В качестве значения Pi использовать 3.14. Программа в паскале.
Ответы (1)
Составьте программу решающую следующую задачу. Известна длина окружности L. Найдите площадь круга S ограниченного этой окружностью. Формулы для вычисления длины окружности и площади круга I=2 пR? S = пR^2 (где п = 3,14)
Ответы (1)
В одной IT-компании на двери установили новый замок, код к которому - последовательность из 5 цифр. Для тех сотрудников, которые забыли код, перед дверью стоит автомат, отвечающий на те вопросы, на которые возможен ответ "да" или "нет".
Ответы (1)
Код строчной латинской буквы 'а' равен 61_16, а заглавной А' - 41_16. Используя логическую операцию "И", преобразуйте код строчной буквы в код заглавной. Проверьте, работает ли предложенный вами метод для других букв.
Ответы (1)
Дан радиус круга. вычислить площадь и длину окружности этого круга в паскале ABC
Ответы (1)