Задать вопрос
25 августа, 08:21

Составьте программу которая определяет номер кординатной четверти в которой находяться точка с кординатой x, y числа x, y вводятся с клавиатуры

+4
Ответы (1)
  1. 25 августа, 09:04
    0
    var x, y, n:integer; / / здесь: x - абсцисса точки, y - ордината точки, n - координатная четверть

    begin

    write ('Введите x - ');

    readln (x);

    write ('Введите y - ');

    readln (y);

    if (x>0) and (y>0) then n:=1;

    if (x0) then n:=2;

    if (x<0) and (y<0) then n:=3;

    if (x>0) and (y<0) then n:=4;

    if (n=1) or (n=4) then

    writeln ('Точка расположена в ', n,'-ой координатной четверти');

    if n=2 then writeln ('Точка расположена во ', n,'-ой координатной четверти');

    if n=3 then writeln ('Точка расположена в ', n,'-ей координатной четверти');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу которая определяет номер кординатной четверти в которой находяться точка с кординатой x, y числа x, y вводятся с ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Составьте программу, которая вычисляет расстояние между двумя городами в километрах К, приняв, что 5 миль равны 8 км. Город А находится в Х милях от Москвы. Значения А и Х вводятся с клавиатуры.
Ответы (1)