Задать вопрос
20 января, 14:58

Напишите программу которая вычисляет площадь кольца, если его толщина t см, а диаметр внутреннего круга-d см (в паскале)

+1
Ответы (1)
  1. 20 января, 17:21
    0
    Program kolco;

    var

    t, d, r, S: real;

    begin

    write ('Введите толщину кольца в см: ');

    readln (t);

    write ('Введите диаметр внутреннего круга в см: ');

    readln (d);

    r:=t+d; {Вычисляем радиус большого круга}

    S=pi*r*r-pi*d*d; {Находим площадь кольца, вычитая из площади большого круга радиуса r площадь малого круга радиуса d}

    writeln ('Площадь кольца равна ', S); {}

    rteadln

    end.

    При возведении в квадрат можно использовать встроенную функцию Pascal: sqr (x).
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу которая вычисляет площадь кольца, если его толщина t см, а диаметр внутреннего круга-d см (в паскале) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы