Задать вопрос
12 ноября, 11:17

Составить программу для решения следующей задачи: Найти натуральное число от 1 до 10000 с с максимальной суммой делителей.

+3
Ответы (1)
  1. 12 ноября, 12:59
    0
    program zz1;

    var n, i, max, k, j:integer; / / задаем переменные целого типа

    begin

    max:=0;

    for j:=1 to 10000 do / / организуем цикл, в котором переберем все числа от 1 до 10 000

    begin

    for i:=1 to j do

    if j mod i = 0 then k:=k + i; / / проверяем число на делимость и получаем сумму делителей

    if k > max then begin max:=k; n:=j; end; / / проверяем на максимальную сумму делителей и запоминаем число

    k:=0; / / обнуляем сумму

    end;

    write (' число с максимальной суммой делителей = ', n); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу для решения следующей задачи: Найти натуральное число от 1 до 10000 с с максимальной суммой делителей. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы