Задать вопрос
25 января, 20:12

Используя цикл с заданным условием продолжения работы написать программу которая вычисляет сумму первых n натуральных чисел

+2
Ответы (1)
  1. 25 января, 20:59
    0
    program zz1;

    var n, r, i : integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим с клавиатуры число

    read (n);

    i:=1; / / задаем начальное значение для первого натурального числа

    while i < = n do / / организуем цикл пока, с заданным условием продолжения работы

    begin

    r:=r + i; / / вычисляем сумму натуральных чисел

    i:=i + 1; / / получаем следующее натуральное число

    end;

    write (' сумма первых, ', n, ' натуральных чисел = ', r); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Используя цикл с заданным условием продолжения работы написать программу которая вычисляет сумму первых n натуральных чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры заменяет все числа в массиве заданным числом
Ответы (1)
Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. Количество чисел должно задаваться во время работы программы. (цикл для) (паскаль)
Ответы (1)
1) Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.2) Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.
Ответы (1)
написать программу, которая вычисляет сумму первых четных целых n положительных чисел, количество суммированных чисел должно вводиться во время работы программы.
Ответы (1)