Задать вопрос
1 ноября, 08:36

Составьте программу, которая запрашивает имя (один из символов: 'а' - Алексей, 'с' - Сергей, 'м' - Михаил, 'к' - Константин) и отчество ('б' - Борисович или 'с' - Сергеевич) и выдаёт их полное название. Протокол: Введите имя и отчество: ссВас зовут Сергей Сергеевич

+1
Ответы (1)
  1. 1 ноября, 12:27
    0
    program name;

    var s, i, o: string;

    begin

    writeln ('Введите инициалы (маленькие буквы, без знаков препинания.');

    writeln ('Имя: а, с, м, к. Отчество: б, с) ');

    readln (s);

    case s[1] of

    'а': i: = 'Алексей';

    'с': i: = 'Сергей';

    'м': i: = 'Михаил';

    'к': i: = 'Константин'

    end;

    case s[2] of

    'б': o: = 'Борисович';

    'с': o: = 'Сергеевич'

    end;

    writeln ('Вас зовут ', i, ' ', o)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая запрашивает имя (один из символов: 'а' - Алексей, 'с' - Сергей, 'м' - Михаил, 'к' - Константин) и отчество ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая запрашивает у пользователя число, но не больше пятизначного, и выдаёт на экран сообщение о том, сколько цифр в данном числе. 0
Ответы (1)
Напишите программу, которая запрашивает четыре целых числа и выдает на экран: 1) сумму чисел; 2) сумму квадратов чисел; 3) среднее арифметическое чисел; 4) сумму парных произведений.
Ответы (1)
Компьютер подключенный к интернету обязательно имеет интернет адрес? Как формируется доменная система имен? Как работает транспортный протокол? Протокол маршрутизации?
Ответы (1)
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1
Ответы (1)
1. Два текста содержат одинаковое количество символов. Первый текст составлен с помощью алфавита, в котором 16 символов. Второй текст составлен с помощью алфавита, в котором 256 символов.
Ответы (1)