Задать вопрос

Какое значение будет принимать переменная Х, после выполнения фрагмента программы: а:=4, b: = 5, с: = 3. If a>b then x:=a+b else begin a:=b+c x: = а - 3*b end. вот варианты ответов: а) 9 б) 7 в) 12 г) - 7

+5
Ответы (1)
  1. 15 апреля, 03:53
    0
    Для того, чтобы определить какое значение будет принимать переменная Х, после выполнения фрагмента исходной программы, пройдем по этой программе вручную следующим образом:

    1) а: = 4, b: = 5, с: = 3.

    2) If a > b then x: = a + b

    4 > 5 - не верно, значит переходим на следующий шаг программы после ключевого слова else:

    3) else begin

    a: = b + c = 5 + 3 = 8; получили, что значение a теперь равняется 8.

    x: = а - 3 * b = 8 - 3 * 5 = 8 - 15 = - 7.

    4) Поскольку следующим идет команда end, значит программа завершает и получаем значение x: = - 7.

    Таким образом правильный вариант ответа - г).
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Какое значение будет принимать переменная Х, после выполнения фрагмента программы: а:=4, b: = 5, с: = 3. If a>b then x:=a+b else begin ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
Какое значение получит переменная z после исполнения следующего фрагмента программы? z : = 5; x : = 1; if z > 0 then z : = 2 * z else x : = 10; if x = 0 then z : = - 2 else z : = 9; if (sqrt (z) = 3) and (x > 1) then z : = z - 8 else z : = 3 * x;
Ответы (1)