Задать вопрос
20 апреля, 05:52

Напишите программу в Паскале, которая определяет среднее арифметическое чисел в интервале от N до N1

+2
Ответы (1)
  1. 20 апреля, 07:03
    0
    var

    x, y, i, s : integer; / / объявляем переменные

    begin

    write ('Введите начало и конец интервала: '); / / выводим строку на экран

    readln (x, y); / / считываем значение переменных, введенных с клавиатуры

    for i : = x to y do / / цикл от первого числа интервала до последнего

    begin

    s:=s+i; / / считаем сумму чисел в интервале

    end;

    writeln (s / (y - x + 1)); / / выводим на экран среднее арифметическое

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу в Паскале, которая определяет среднее арифметическое чисел в интервале от N до N1 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
1. напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных семи и оканчивающихся на один количество не известно 2.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)