Задать вопрос

Программа которая переводит десятичное число в восьмеричное паскаль

+2
Ответы (1)
  1. 4 апреля, 13:16
    0
    program zz1;

    var n, i, s:integer; / / вводим переменные целого типа

    c:string;

    begin

    write (' введите десятичное число ');

    read (n); / / вводим число с клавиатуры

    while n > 0 do / / переводим в систему с основанием 8

    begin

    s: = n mod 8; / / получаем цифру числа с основанием 8

    c:=c + inttostr (s); / / переводим число в строку и дописываем ее в строку

    n:=n div 8; / / отбрасываем цифру из числа

    end;

    for i:=length (c) downto 1 do / / организуем цикл, в котором прочитаем с конца

    write (c[i]); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Программа которая переводит десятичное число в восьмеричное паскаль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Установите соответствие: 1) базовое системное ПО а) операционная система 2) утилиты б) программа диагностики дисков в) антивирусная программа г) операционная оболочка д) программа архивации данных e) программа обслуживания сети
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Автомат получает на вход трёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первой и второй цифр и сумма третьей и четвёртой цифр заданного числа. 2.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)